No compatible version found: @types/react-dom@15.4.2

Solution

Was puzzled by the

No compatible version found: @types/react-dom@15.4.2

In the end chaning all of the react related vers to

"^15.4.1",

did the trick

also had an error (2nd one bellow); but that was due to a server already running on the same port

Problem

npm install
▌ ╢░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░╟
▀ ╢░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░╟
npm ERR! Linux 4.4.0-59-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2

npm ERR! No compatible version found: @types/react-dom@15.4.2
npm ERR! Valid install targets:
npm ERR! 0.14.21, 0.14.20, 0.14.19, 0.14.18, 0.14.17, 0.14.16, 0.14.15, 0.14.14, 0.14.13, 0.14.12-alpha, 0.14.11-alpha, 0.14.10-alpha, 0.14.9-alpha, 0.14.8-alpha, 0.14.7-alpha, 0.14.2-alpha, 0.14.1-alpha
npm ERR! 
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR! <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR! /home/neil/MEGA/MEGAsync/docs/projects/patentBot/code/patentBotUI/npm-debug.log

 

npm start

> mobx-react-typescript-boilerplate@1.0.0 start /home/neil/MEGA/MEGAsync/docs/projects/patentBot/code/patentBotUI
> node server.js

events.js:141
 throw er; // Unhandled 'error' event
 ^

Error: listen EADDRINUSE 127.0.0.1:3000
 at Object.exports._errnoException (util.js:870:11)
 at exports._exceptionWithHostPort (util.js:893:20)
 at Server._listen2 (net.js:1237:14)
 at listen (net.js:1273:10)
 at net.js:1382:9
 at GetAddrInfoReqWrap.asyncCallback [as callback] (dns.js:63:16)
 at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:82:10)

npm ERR! Linux 4.4.0-59-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
npm ERR! node v4.2.6
npm ERR! npm v3.5.2
npm ERR! code ELIFECYCLE
npm ERR! mobx-react-typescript-boilerplate@1.0.0 start: `node server.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the mobx-react-typescript-boilerplate@1.0.0 start script 'node server.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the mobx-react-typescript-boilerplate package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node server.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs mobx-react-typescript-boilerplate
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls mobx-react-typescript-boilerplate
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/neil/MEGA/MEGAsync/docs/projects/patentBot/code/patentBotUI/npm-debug.log

 

 

 

 

About Neil Rubens

see http://ActiveIntelligence.org
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *


*